Skip to main content

Southwest Airlines Community

Highlighted

Southwest App does not work on older iPads and iPhones and thus can't use In-flight entertainment

New Arrival

Anyone with older, but still very usable, Apple products are unable to use the Southwest app or the in-flight entertainment that requires the Southwest app to work. 

 

My iPad and iPhone has the max IOS version Apple lets us use and the Southwest app will not install. One of my older iPad's has the Southwest app installed and it says I must upgrade it to latest version when launching it, which is impossible to do. 

 

I use my older Apple products daily and have never had an app not install because the app provider doesn't know what they are doing. United, Delta and American Airlines apps all work on all my older devices.  

 

Not fixing this would be akin to not flying Southwest unless they only flew the newest model planes.

 

2 REPLIES 2

Re: Southwest App does not work on older iPads and iPhones and thus can't use In-flight entertainmen

Top Contributor
Solution

For various reasons, perhaps a mixture of security and features, Southwest has chosen to set a minimum OS level that does seem to be higher than other airlines. Perhaps they're being overly cautious or perhaps cutting-edge, but whatever the reason it unfortunately means you won't be able to use older devices. 

 

--TheMiddleSeat

Highlighted

Re: Southwest App does not work on older iPads and iPhones and thus can't use In-flight entertainmen

Rising Star

The Southwest web site says that for mobile devices and tablets, you need IOS 11 or above for the devices to work properly during a flight. Regarding the app, the app also requires IOS 11 or above, as stated in the App Store. Apps do need to be kept up to date because older versions of the app become less stable / unusable with later IOS upgrades that become released. 

 

Assuming you are on at least IOS 11 and the app is up to date, you should be able to use it during your flight. 

 

My guess is you are using an older IOS, and that is why you are having problems. 

 

--Jessica