Skip to main content

Southwest Airlines Community

[BUG] There is no field to add rapid rewards number for the companion.

10kd
New Arrival

[BUG] There is no field to add rapid rewards number for the companion.

After adding the companion, the companion is assigned a random rapid rewards number that cannot be changed in the online UI.

5 REPLIES 5

Re: [BUG] There is no field to add rapid rewards number for the companion.

dfwskier
Top Contributor

You could contact SW via e-mail or social media. To do so click on "contact us" below.

Re: [BUG] There is no field to add rapid rewards number for the companion.

bec102896
Top Contributor

In my experience when I typed the companions info exactly as it appears on their RR account (including their address) it would auto populate their RR number once the companion is assigned. When you add the companion for the first time on the website you can’t add the RR number to the info being entered hopefully that will change though in the future. 


for the sake of getting the RR number corrected I would reach out to reservations at 800-435-9792 or reach out on Facebook or Twitter and they can assist 

 

-Blake 

Re: [BUG] There is no field to add rapid rewards number for the companion.

10kd
New Arrival

Thanks for the responses.  I was hoping that posting here will let Southwest see it and acknowledge it as a bug.  Of course customer service can always help change it (up to 3 times a year on companion details)

Re: [BUG] There is no field to add rapid rewards number for the companion.

TheMiddleSeat
Top Contributor

@10kd This is a customer to customer community, Southwest is not monitoring for feedback here.

 

--TheMiddleSeat

Re: [BUG] There is no field to add rapid rewards number for the companion.

parpitt1
Active Member

Good thought, but as noted this is a customer forum. When I set up my wife as a companion it flows automatically with her RR# number along with her KTN.

I do this on a full function laptop not a phone or Tablet. "App" Full-functionality can be very suspect with alot of airline websites. Maybe that's the problem?